Announcement

Collapse
No announcement yet.

Custom website not running in WHM/cPanel in a VPS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Custom website not running in WHM/cPanel in a VPS

    My websites are hosted on different VPS in different companies and different WHMs. One strange thing is happening that one of my custom websites is working on VPS1 and WHM/cPanel but isn't running on VPS2 and WHM/cPanel. I think it's happening because there is difference in configurations of different companies or PHP/MySQL isn't compatible witn the custom website on VPS2. What should I check in WHM or suggestions to fix the problem?

  • #2
    How did you know it couldn't run? What are the errors you get?

    Comment


    • #3
      The web pages are showing the error "an error occurred while processing this directive". After research on Google for this error, I found the suggestions to chane the folder/file permissions in the public_html and so I chmod 755 for all files and folders in public_html. It immediately redirects a my search file with blank page. I am searching for this file and so I think the custom codes aren't compatible with server configs on VPS2.

      Comment


      • #4
        Try using the permissions below -

        owner should be 'accountname' group 'nobody'

        The public_html folder should always have 0750 permissions.
        All folders inside the public_html folder should have 0755 permissions.
        All files inside the public_html folder should have 0755 or 0644 permissions.

        Comment


        • #5
          VPS2 should also be able to run your website regardless. You said the public_html folder is 755 could you ensure the files inside also have the right permissions.

          Comment


          • #6
            I think it isn't the problem on setting up permissions for files or folders because on VPS1, I haven't set anything for files/folders on VPS2 but it ran.
            I installed WHM/cPanel and left default setting for VPS2 while my hosting provider has installed WHM/cPanel on my VPS1 for me and they sent me the account but only with some features.

            Comment


            • #7
              Originally posted by Mathew McGuire: I think it isn't the problem on setting up permissions for files or folders because on VPS1, I haven't set anything for files/folders on VPS2 but it ran.
              I installed WHM/cPanel and left default setting for VPS2 while my hosting provider has installed WHM/cPanel on my VPS1 for me and they sent me the account but only with some features.
              Can you send me the php.ini from both of your VPS since you believe the issue might be from your PHP?

              Comment


              • #8
                Originally posted by Elizabeth Anderson: Can you send me the php.ini from both of your VPS since you believe the issue might be from your PHP?
                Surely I will send you Php.ini files from both VPS for checking some things on them.
                I supposed that it has different configurations in PHP/MySQL, versions or VPS settings.

                Comment


                • #9
                  I myself run multiple sites in various niches and have never hosted my properties on different hosts, why would anyone even risk hosting their properties on different hosts in the first place?

                  Comment

                  Working...
                  X